Storm Android Library installation

In order to use create a player compatible with Storm Streaming Server in an Android application, StormLibrary is required. It can be obtained in two ways:

Installation with the Gradle tool (recommended)

  1. Create/open your application in Android Studio
  2. In file project build.gradle add new repository jitpack.io:
                                    
    implementation 'com.github.StormStreaming:stormlibrary-android:vx.y.z'
    implementation 'com.google.android.exoplayer:exoplayer-core:2.13.2'
    implementation 'com.google.android.exoplayer:exoplayer-ui:2.13.2'
                                
    Don't forget to replace x.y.z form the sample with valid major, minor, patch version. The current version can be found at: https://github.com/StormStreaming/stormlibrary-android/releases.
  3. In file build.gradle add the following dependency:
                                    
    allprojects {
        repositories {
            …
            maven { url 'https://jitpack.io' }
        }
    }
                                
  4. In file build.gradle configure compileOptions, so the application uses Java 8. Also set multiDexEnabled to true
                                    
    android {
        defaultConfig {
            ...
            minSdkVersion 21
            multiDexEnabled true
        }
        ...
        compileOptions {
            sourceCompatibility = '1.8'
            targetCompatibility = '1.8'
        }
    }
                                
  5. In gradle.properties set both android.useAndroidX and android.enableJetifier to true
                                    
    # Project-wide Gradle settings.
    
    android.useAndroidX=true
    android.enableJetifier=true
    
                            
  6. Synchronize Gradle

Installation though github project download

Please keep in mind that in order for Storm Android Library to work ExoPlayer library is also required. If you wish to install it, just add the following code to the build.gradle file (dependency section):

                                
implementation 'com.google.android.exoplayer:exoplayer-core:2.13.2'
implementation 'com.google.android.exoplayer:exoplayer-ui:2.13.2'

                    

Installation guide - step by step